Close

Flash plug-in blocked with certain versions of Chrome

If you are playing Battle Pirates on Version 40.0.2214.91 for Chrome, you may see the following screen when trying to access the game regardless of the platform you are currently playing on.

To fix this simply go to the top right hand side of your screen, and in the address bar click the puzzle piece icon with the red "x"

In the drop down that follows change the setting from "Continue blocking plug-ins" to "Always allow plug-ins" (the address shown in the screenshot is for Facebook, but you may see a different address depending on which platform you are playing Battle Pirates on), and then click done.

This will reload the game and get you back on the High Seas.

 

 
Was this article helpful?
0 out of 3 found this helpful
Follow

Comments